Issue
How do I run a period update when the foreign bank account has a negative balance?
Cause
There are two scenarios which can cause this issue:
Scenario 1
For the first-year fund on Class, you could refer the following article.
Scenario 2
For the non-first-year fund on Class, there is a Cash Out transaction with the amount exceeding the current balance during the financial year.
Resolution
Class does not support a negative ending balance for the foreign bank account. You are required to remove the cash transaction to bring the foreign bank account balance to zero.
The workaround to resolve this issue is:
Create a custom holding account to handle the cash transaction which triggers a negative balance, to retain a zero or positive balance in the foreign cash account.
- Create Custom Holding Account. The User Guide provides instructions for creating a Custom Holding Account.
Navigate to Fund level > Transactions > Browse Bank Statements > select the custom holding account you created
- Create a Cash Out transaction with AUD equivalent for the foreign cash transaction which triggers the negative balance and leave it as "unmatch"
- Add a Cash Out transaction in the foreign bank account when the foreign cash account has sufficient funds to handle this Cash Out transaction
- Create a Cash In transaction in custom holding account which is handling negative foreign bank account balance
- Match the cash transactions created in Step 1 and Step 3 in Transactions > Match Transactions screen
For further information on other period update errors, refer to Period Update Error Messages: Summary