Issue
What does the error 'The envelope exists. Please refresh and retry' mean when sending report packages for signature?
Cause
There are two possible causes for this message:
1. The envelope already exists and is no longer in Draft status. This may be because the status of the envelope has changed and it's not reflecting the correct status in the report pack history screen
2. docusign cannot be opened as the length of the e-mail subject in docusign, which Class automatically populates, exceeds 100 characters.
Class automatically populates the e-mail subject for Report Package envelopes, to be a combination of:
- The report package name and
- The Entity name.
Resolution
- To resolve the first cause, click Refresh in the Report Pack screen to reflect the latest status of the envelope
- To resolve the second cause:
Shorten the length of the report package name so that the combined subject line (report package name and entity name) doesn't exceed 100 characters.
Then, recreate the envelope and resend for signature.