Query
The feed has started, and all investments have doubled up.
Cause
At the time of data feed set up, investment accounts were not linked. As a result, when the data feed is activated, it will create the investment accounts for each investment that Class receives in the data file from the provider.
Solution
Navigate to Fund Level > Feeds > Feeds Console
- Click on Feed > correctly link the relevant holding accounts.
Navigate to Fund Level > Investments > Browse Holding Accounts
- Tick on "Show Zero Balances"
- Click on each duplicated investment account > Edit > Update the "Description"
(This is to differentiate between the original investment account and duplicated investment account) - Follow the steps below as per "Navigate to Transactions > Browse Events"
- Click on each duplicated investment account > Edit > Delete
Navigate to Fund Level > Transactions > Browse Events
- Group the transactions by "Account Name"
- Locate the investment account with the description updated above
- Click on each transaction under the investment account > Edit > Update the "Investment Account" to relink with the correct holding account.
Delete any events that have duplicated.
The feed balance will be correctly applied to the original holding accounts once the Data Feeds re-sync. It will usually occur overnight.