Issue
The tax agent details are not pre-filling the Annual Return, Section K.
After finalising the tax return, the tax agent contact details are blank in Section K, and the tax agent's name needs to be manually selected from the drop down menu.
Cause
There are two possible causes of this issue:
- At the Business Level, the Tax Agent is setup as an Organisation
- The Tax Agent is set up as a person, however, they have not been related to this fund
Resolution
This issue can be resolved by either creating a new person with the role of Tax Agent or relating the tax agent to the fund.
Tax Agent is setup as an Organisation
Navigate to Business Level > Business > Business Contacts
- Create a New Person with the Role as Tax Agent
- Business > Business Details, set the newly created Tax Agent as Default
- Regenerate the return (newly created tax agent will show on Annual Return for ATO to contact)
Tax Agent is setup as a person and is not related to the fund or the whole Business
Navigate to Business Level > Business > Business Contacts
- Click on the person
- From the pop-up screen, go to Relationship
- Relate to either Business, Brand or Fund, depending on your Business' structure