Issue
Period update error - "All transactions should be for valid amounts" occurred when running period update
Cause
This is usually caused by an unusually large market value of an investment account, which is usually incorrect (e.g. a valuation of more than $100 billion dollars)
Resolution
Navigate to Fund Level > Investments > Browse Holding Accounts
- Look for investments whose amount is unusually large
- Click on the 3 dots radio button next to the investment account
- Select Holding Prices/ Valuations
- Click on Edit/Delete for the relevant effective date
- Adjust the valuation to the correct amount
If you select Price as Type, enter the unit price of the investment asset
- Save