Issue
When processing a Period Update, an error message appears.
“Cannot perform Benefit Allocation - Asset Pool (default pool) has total member account weighted balance equal to zero.”
Cause
In order to process the rollover/lump sum event, there is a Period Update run one day before the rollover/lump sum date. After the rollover/lump sum out event, all member accounts are zero.
If the fund receives income e.g. bank interest, or pays expenses e.g. bank fees, these business events are processed after the rollover/lump sum out event.
What is the result? Class is not able to allocate the profit or loss to member accounts (based on the member's weighted average balances) as the member balances are zero.
Resolution
The resolution is dependent upon the scenario:
Scenario 1: The trustee has not taken the rollover or lump sum
Scenario 2: The trustee has taken the rollover or lump sum
Let's have a look at each of the above scenarios in turn.
The trustee has not taken the rollover or lump sum
In this scenario, the rollover/lump sum event can be deleted and reprocessed.
- Delete the current rollover or lump sum event
- Re-process the final rollover/lump sum out event to include these income and expenses.
The trustee has taken the rollover or lump sum based on the current business events
In this scenario, the rollover/lump sum event cannot be deleted and reprocessed. Take the following steps to solve this issue:
- Roll back the last period update
- Run a period update to the winding up date. Ignore the period update notification saying to one day before the rollover/lump sum date
- Class will allocate the profit and loss
If the residual member account is positive, process another Rollover/Lump Sum Out event to reduce the member balance to zero.
If the residual member account is negative, professional advice should be sought. Trustees may need to make a payment into the fund to cover the expense.
The income/expenses after the rollover transaction date are very small or only tax statements are processed after the rollover transaction date
You may consider:
- Moving those events' date to before the 'rollover/lump sum date'
- Reprocess the Period Update to clear the Modified Events
For further information on other period update errors, refer to Period Update Error Messages: Summary